4dsdev
Views: 613,822 Main | Rules/FAQ | Memberlist | Active users | Last posts | Calendar | Stats | Online users | Search 11-22-17 02:40 AM
Guest:

Main - Posts by Wowfunhappy


Wowfunhappy
Posted on 04-05-15 05:55 PM, in Certain apps crash on launch; problem is persistent across NAND images. (rev. 6 of 04-05-15 11:35 PM) Link | #118
Hi! I posted about this on GBATemp, but it's been three days and no one has been able to provide useful information, so I thought it would be worth asking here.

I have a NAND-modded, small New 3DS. I paid someone else to install the mod for me, and I'm relatively confident he did a good job. I did not begin having problems until a while after the mod was installed.

I had successfully performed an EU -> US region change, and was flashing back and forth between different NAND images. For a while, this worked fine.

At one point, however, I went from a 9.6 US NAND to a 9.6 EU NAND. I had successfully done this at least once before, but this time, something went wrong. Upon trying to open certain applications and applets, the system would crash to a black screen (with the standard error message).

No problem, I figured—I had tons of NAND backups. I first tried flashing my 9.6 US NAND image, which had been working fine less than an hour ago. Same issue. I have since tried flashing other images, all of which were previously working fine. The problem refuses to go away.

Firmwares 9.0–9.2 run perfectly, but the problem returns as soon as I run a system update. I have not tested 9.3, but firmwares 9.4, 9.5, and 9.6 all experience the issue.

Does anyone know what could be happening here? What could cause an issue to persist across different NAND images? And lastly, is there any place other than the NAND and SD Card where rewritable data is stored? Thank you so much!

Things I have tried:
-Removing/replacing/reformatting the SD card.
-Verifying that images are being written properly.
-Disabling Wifi.
-Updating via a Xenoblade game cart.
-Performing a system format before updating.

Broken Software:
-NNID Settings
-Camera Applet
-Face Raiders
-Notifications
-Xenoblade
-eShop
-Amiibo Settings
-Streetpass Plaza
-MiiVerse, but only when an NNID is linked

Working Software
-AR Games
-Web Browser
-Cubic Ninja
-Friends List
-Activity Log
-Camera Application
-Mii Maker
-Download Play
-3DS Sound
-Health & Safety
-Game Notes
-MiiVerse when no NNID is linked

Wowfunhappy
Posted on 04-05-15 06:31 PM, in Certain apps crash on launch; problem is persistent across NAND images. (rev. 3 of 04-05-15 06:33 PM) Link | #120
Posted by StapleButter
This looks related to online functionality, but not entirely sure. Weird.

Maybe Nintendo detected your shit and banned you from their services. That doesn't explain all of it, though.

I thought of that, but I performed an experiment which (I think) makes it impossible:

1) Disable WiFi
2) Flash vanilla NAND (made long before I started messing with stuff)
3) Update via Xenoblade

After the above steps, the problem is still present, even though this NAND has not been connected to the internet in almost a month.

Plus, the apps crash within two seconds of being launched, if even that much. The app never starts—the crash happens midway through the "Nintendo 3DS" loading animation. In that little time, it's hard to believe that the program is getting instructions from the internet.

Wowfunhappy
Posted on 04-06-15 12:16 AM, in Certain apps crash on launch; problem is persistent across NAND images. Link | #122
Posted by StapleButter
All I can think of is something getting stored somewhere else than in the NAND (or in some NAND spot that didn't get affected by your flashes), and fucking things up.


Does this exist? I know that keys etc are stored in the CPU, but that's read-only.

Wowfunhappy
Posted on 04-06-15 08:14 PM, in Certain apps crash on launch; problem is persistent across NAND images. Link | #124
ErrDisplay log:
PID:0x00040130_00004002
REV:0061031
AID:0xFFFFFFFF_FFFFFFFF
ADR:0x00101E6C
RSL:0xF9617590
Exact same entry was generated five times from launching five different apps.

0004013000004002 is the NFC title, which was updated on 9.3, so that explains why the error doesn't occur on 9.0-9.2.

Wowfunhappy
Posted on 04-13-15 05:49 PM, in Certain apps crash on launch; problem is persistent across NAND images. Link | #126
Installing the Old 3DS NFC module actually (for whatever reason) allows most of the broken apps to launch under 9.4. A few—namely, the ones that actually use NFC, such as Amiibo settings—crash to the home menu (although not a black screen!), but it's still a massive improvement. On 9.6, however, it just causes infinite loading screens.

For whatever it's worth: the problem has randomly disappeared twice. The first time it happened was in USA 9.6 firmware. Everything continued to work even after rebooting the console, but broke again after I connected my NAND mod (to back up the NAND—I didn't write anything!).

It fixed itself again yesterday, on EU 9.6. This time, however, it only lasted until I rebooted the console. In both cases, I cannot for the life of me think of anything special that I did.


Main - Posts by Wowfunhappy

Page rendered in 0.051 seconds. (2048KB of memory used)
MySQL - queries: 22, rows: 69/69, time: 0.036 seconds.
[powered by Acmlm] Acmlmboard 2.064 (2015-10-07)
© 2005-2008 Acmlm, Xkeeper, blackhole89 et al.